Incident notification

Incident Report for PandaDoc

Monitoring

We have deployed a fix for document management features and are monitoring the system to confirm full recovery. As we finish reprocessing failed events and the service stabilizes, some customers may still briefly experience issues creating, opening, or downloading documents or templates.
Posted Sep 06, 2026 - 21:16 PDT

Identified

We have confirmed that document management features are unavailable or degraded for affected customers. You may be unable to create, open, or download documents/templates via the app or PandaDoc API. Our team is actively working on a resolution.

Next update in ~30 minutes.
Posted Sep 06, 2026 - 20:35 PDT

Update

We are continuing to investigate this issue.
Posted Sep 06, 2026 - 19:52 PDT

Investigating

We are receiving reports that document management features may be unavailable for some customers. You may be unable to open, download, or archive documents. We are actively investigating the issue and will share updates as soon as more information becomes available.

Next update in ~30 minutes.
Posted Sep 06, 2026 - 19:47 PDT
This incident affects: US & Global (Creating and editing documents, Sending documents, Uploading documents, API, Downloading documents).