Some customers may not be able to sign documents and will only see a loading screen
Incident Report for PandaDoc
Resolved
This incident has been resolved.
Posted Apr 29, 2022 - 08:54 PDT
Update
For any urgent cases, as a workaround signatures will work normally using PandaDoc on your mobile device. You can try opening docs from a mobile app/browser and sign documents from there. We do apologize for the inconvenience caused and are working diligently to resolve the issue.
Posted Apr 29, 2022 - 08:13 PDT
Investigating
We are currently investigating this issue.
Posted Apr 29, 2022 - 07:38 PDT
This incident affected: US & Global (Web application).