Unable to download documents
Incident Report for PandaDoc
Resolved
We're all set! Users can now download documents. If you continue to experience any issues with this, please reach out to us at support@pandadoc.com.
Posted Jul 28, 2022 - 11:31 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 28, 2022 - 09:27 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2022 - 09:18 PDT
Update
We are continuing to investigate this issue. We will keep you updated as the situation develops.
Posted Jul 28, 2022 - 08:52 PDT
Update
We are actively investigating the issue with completed document downloads. Please check back here for updates, and we appreciate your patience while we get this resolved.
Posted Jul 28, 2022 - 08:23 PDT
Investigating
We are currently investigating this issue.
Posted Jul 28, 2022 - 08:20 PDT
This incident affected: US & Global (Uploading and downloading documents).