Issue with Identity Verification (Persona)

Incident Report for PandaDoc

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 01:25 PDT

Investigating

We’re currently experiencing issues with identity verification due to an incident on our third-party provider’s side (Persona).
Impact:
Notarization: Persona verification is unavailable.
Workaround: Please use Personally Known verification instead.
Document Verification (ID Check): ID Check for Advanced Verification may not function as expected.
Workaround: You can switch the recipient’s verification method to another available type, such as Knowledge-Based Authentication (KBA).
Instructions: KBA Setup Guide
We recommend using these alternatives until the issue with Persona is resolved. Our team is monitoring the situation closely.
Posted Jun 12, 2025 - 12:13 PDT