Forms cannot be opened by recipients
Incident Report for PandaDoc
Resolved
We’re all set! If you still experience any issues with opening Forms, please reach out to us at support@pandadoc.com.
Posted Apr 21, 2022 - 07:28 PDT
Monitoring
Our engineers have deployed a fix. Recipients should now be able to open Forms. We’re still monitoring the application performance and will post a final ALL SET message when we’re sure the issue is fully resolved.
Posted Apr 21, 2022 - 07:23 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 21, 2022 - 07:13 PDT
Investigating
We are currently investigating this issue.
Posted Apr 21, 2022 - 06:53 PDT
This incident affected: US & Global (Sending and opening documents).