Issues with documents visibility and movement in the "Documents" tab

Incident Report for PandaDoc

Resolved

This incident has been resolved.
Posted May 12, 2023 - 07:09 PDT

Investigating

We are actively investigating issues with documents visibility and movement in the "Documents" tab. Please check back here for updates, and we appreciate your patience while we get this resolved.
Posted May 12, 2023 - 05:44 PDT
This incident affected: US & Global (Web application).