PandaDoc performance: catalog CSV import
Incident Report for PandaDoc
Resolved
We're all set! If you continue to experience any issues with the application, please reach out to us at support@pandadoc.com.
Posted Apr 27, 2023 - 09:39 PDT
Monitoring
PandaDoc performance has been stabilized. We're still monitoring the application performance and will post a final “ALL SET” message once we’ve confirmed the issue is fully resolved.
Posted Apr 27, 2023 - 09:19 PDT
Investigating
We are actively investigating the issues with catalog CSV import and slow PandaDoc performance (smart content and email delivery included).
Please check back here for updates, and we appreciate your patience while we get this resolved.
Posted Apr 27, 2023 - 09:04 PDT
This incident affected: US & Global (Creating and editing documents, Sending and opening documents, Web application).