Document access in editor

Incident Report for PandaDoc

Resolved

We're all set! PandaDoc is working properly and the incident has been fully resolved.
If you continue to experience issues with this, please contact our Support team (https://support.pandadoc.com/en/articles/9715061-how-to-contact-pandadoc-support).
Posted Jul 28, 2025 - 09:37 PDT

Identified

We’ve identified the issue and are already working on a fix.
We appreciate your patience and will post updates here as soon as possible. Stay tuned!
Posted Jul 28, 2025 - 09:02 PDT
This incident affected: US & Global (Creating and editing documents, Sending and opening documents, Uploading and downloading documents).