PandaDoc is responding slowly / Templates not visible / Document creation may be affected

Incident Report for PandaDoc

Resolved

We're all set! PandaDoc is working properly and the incident has been fully resolved.
If you continue to experience issues with this, please contact our Support team (https://support.pandadoc.com/en/articles/9715061-how-to-contact-pandadoc-support).
Posted Apr 30, 2026 - 13:53 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 30, 2026 - 13:40 PDT

Investigating

We are currently investigating the issue.
Posted Apr 30, 2026 - 13:23 PDT
This incident affected: US & Global (Creating and editing documents, Sending and opening documents, Uploading and downloading documents, Public (recipient) view, API, Website) and EU (Creating and editing documents, Sending and opening documents, Uploading and downloading documents, Public (recipient) view, API, Website).