Incident notification
Incident Report for PandaDoc
Resolved
We're all set! PandaDoc is working properly and the incident has been fully resolved.
If you continue to experience any issues with this, please reach out to us at support@pandadoc.com.
Posted Mar 06, 2024 - 08:53 PST
Investigating
We are actively investigating the ongoing issue of the missing signatures on documents. Please check back here for updates, and we appreciate your patience while we get this resolved.
Posted Mar 06, 2024 - 08:05 PST
This incident affected: US & Global (Uploading and downloading documents, Web application).