Slight Performance Degradation in Editor

Incident Report for PandaDoc

Resolved

We're all set! Users can now create documents with no degradation. If you continue to experience any issues with this, please reach out to us at support@pandadoc.com.
Posted Jun 09, 2023 - 13:52 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 09, 2023 - 11:28 PDT

Update

We are continuing to work on a fix for this issue. We appreciate your patience and will post updates here as soon as possible. Stay tuned!
Posted Jun 09, 2023 - 04:16 PDT

Update

We are continuing to work on a fix for this issue. Check back here for more updates.
Posted Jun 09, 2023 - 03:16 PDT

Update

We are continuing to work on a fix for this issue. We appreciate your patience and will post updates here as soon as possible. Stay tuned!
Posted Jun 09, 2023 - 02:20 PDT

Update

We are continuing to work on a fix for this issue. Check back here for more updates.
Posted Jun 09, 2023 - 01:13 PDT

Update

We are continuing to work on a fix for this issue. We appreciate your patience and will post updates here as soon as possible. Stay tuned!
Posted Jun 08, 2023 - 23:48 PDT

Update

We are continuing to work on a fix for this issue. Check back here for more updates.
Posted Jun 08, 2023 - 22:20 PDT

Update

We’ve identified the issue with slight performance degradation working with the content editor and are already working on a fix. We appreciate your patience and will post updates here as soon as possible. Stay tuned!
Posted Jun 08, 2023 - 20:27 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 08, 2023 - 19:29 PDT

Investigating

We’re on it! Our team has gotten to work resolving this issue to get you back on track as soon as possible. Please check back here for updates.
Posted Jun 08, 2023 - 19:07 PDT

Update

We are continuing to work on a fix for this issue.
Posted Jun 08, 2023 - 18:01 PDT

Identified

We’re experiencing slight performance degradation working with the content editor. The root cause has been identified and solution is in progress.
Posted Jun 08, 2023 - 17:17 PDT
This incident affected: US & Global (Creating and editing documents).