There may be disruptions in PandaDoc services
Incident Report for PandaDoc
Resolved
At this time, the application should work properly. We continue monitoring the situation.
If you continue to experience any issues with this, please contact us at support@pandadoc.com.
Posted Jul 15, 2024 - 09:45 PDT
Update
We are continuing to investigate this issue.
Posted Jul 15, 2024 - 08:57 PDT
Investigating
We are actively investigating the disruptions in PandaDoc services. Please check back here for updates, and we appreciate your patience while we get this resolved.
Posted Jul 15, 2024 - 08:55 PDT
This incident affected: US & Global (Creating and editing documents, Sending and opening documents, Uploading and downloading documents, Public (recipient) view, CRMs & Integrations).