Limited ability in editing sent documents

Incident Report for PandaDoc

Resolved

We're all set! PandaDoc is working properly and the incident has been fully resolved.
If you continue to experience issues with this, please contact our Support team (https://support.pandadoc.com/en/articles/9715061-how-to-contact-pandadoc-support).
Posted Jul 01, 2026 - 13:56 PDT

Update

We've confirmed that editing is currently unavailable for document sent more than 30 days ago. Affected clients may experience unresponsive editor behavior when attempting to edit such documents. Our team is actively working to resolve it.
Posted Jul 01, 2026 - 05:28 PDT

Identified

We’ve identified the issue with editing sent documents and are already working on a fix. We appreciate your patience and will post updates here as soon as possible. Stay tuned!
Posted Jun 30, 2026 - 14:46 PDT
This incident affected: US & Global (Creating and editing documents).